ETI ThermaLib SDK - Version 3

The ThermaLib SDK, available for both Android and iOS, makes it easy to create apps that communicate with ETI’s range of Bluetooth Low Energy thermometers, by handling all communications specifics (communication protocols, error handling) and presenting instrument functionality in terms of convenient programming objects.

Supported Instruments

v3.0 only supports for following Bluetooth LE thermometers:

  • BlueTherm One LE
  • ThermaPen Blue
  • ThermaQ Blue
  • RayTemp Blue
  • TempTest Blue
  • DishTemp Blue

All instrument functionality, which varies from instrument to instrument, is made available by the ThermaLib SDK. Please see individual product documentation for details.

Package Contents

AndroidiOSWindows
Library.aar libraryuniversal static (.a) library.dll library
Sample appsKotlin, JavaObjective-C, SwiftC#
API documentationHTMLHTMLHTML

The packages are accompanied by a release note for the corresponding platform, detailing:

  • how to incorporate the SDK into an app project
  • significant changes from previous releases

Prerequisites

AndroidiOSWindows
OS versionminimum SDK 21
(Lollipop)
Minimum iOS 11.0Windows 10, .NET 4.7.2+
Sample appsKotlin, JavaObjective-C, SwiftC#
API referenceHTMLHTMLHTML
IDE for sample appsAndroid Studio 3.6 or laterXCode 11 or laterVisual Studio

Contact

Any queries regarding this new SDK release, or any other software development enquires for ETI Ltd thermometers, should be emailed to ross.adams@etiltd.co.uk


Product successfully added to the product comparison!